39 lines
725 B
Nix
39 lines
725 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
};
|
|
outputs = { self, nixpkgs, ... }: {
|
|
packages.x86_64-linux = let
|
|
pkgs = import nixpkgs {
|
|
system = "x86_64-linux";
|
|
};
|
|
in {
|
|
pw-on-air = pkgs.rustPlatform.buildRustPackage rec {
|
|
pname = "pw-on-air";
|
|
version = "0.1.0";
|
|
|
|
src = ./.;
|
|
|
|
nativeBuildInputs = with pkgs; [
|
|
pkg-config
|
|
rustPlatform.bindgenHook
|
|
];
|
|
|
|
buildInputs = with pkgs; [
|
|
pipewire
|
|
];
|
|
|
|
cargoLock.lockFile = ./Cargo.lock;
|
|
|
|
};
|
|
default = self.packages.x86_64-linux.pw-on-air;
|
|
};
|
|
|
|
hydraJobs = {
|
|
inherit (self)
|
|
packages;
|
|
};
|
|
};
|
|
}
|
|
|