1
0
Fork 0
vcp-bula-nixfiles/packages/ptlib.nix

27 lines
555 B
Nix

{ stdenv, fetchurl, pkg-config, flex, bison }:
let
pname = "ptlib";
version = "2.18.6";
hash = "sha256-31HndbsCS73uU0yvJW7/YA7s56+9V2itafuLPqllE2Y=";
in stdenv.mkDerivation {
inherit pname version;
src = fetchurl {
url =
"mirror://sourceforge/project/opalvoip/v3.18%20Cygni/Stable%206/ptlib-${version}.tar.bz2";
inherit hash;
};
#patches = [
# ./ptlib-pidfile.patch
#];
buildInputs = [ pkg-config ];
nativeBuildInputs = [ flex bison ];
#NIX_CFLAGS_COMPILE = [ "-fpermissive" ];
#CXXFLAGS = "-std=gnu++98";
}