1
0
Fork 0
vcp-bula-nixfiles/hosts/router/203-net-hospital.nix

61 lines
1.3 KiB
Nix

{ config, pkgs, ...}:
{
networking.vlans."net-hospital" = {
id = 203;
interface = "ens18";
};
networking.interfaces.net-hospital.ipv6.addresses = [
{ address = "fe80::1"; prefixLength = 64; }
{ address = "fd00:10:42:203::1"; prefixLength = 64; }
];
networking.interfaces.net-hospital.ipv4.addresses = [
{ address = "10.42.203.1"; prefixLength = 24; }
];
services.radvd.config = ''
interface net-hospital {
AdvSendAdvert on;
MaxRtrAdvInterval 30;
prefix ::/64 {
AdvValidLifetime 60;
AdvPreferredLifetime 30;
};
RDNSS 2a01:4f8:1c0c:8221::8 {};
DNSSL bula22.de {};
};
'';
services.kea.dhcp4 = {
settings = {
interfaces-config = {
interfaces = [ "net-hospital" ];
};
subnet4 = [
{
id = 203;
subnet = "10.42.203.1/24";
pools = [
{
pool = "10.42.203.100 - 10.42.203.240";
}
];
option-data = [
{
name = "routers";
data = "10.42.203.1";
}
];
}
];
};
};
clerie.forward-filter.interfaces.net-hospital.rules = [
{ incomingInterface = "net-ikt"; }
];
clerie.uplink-selector.interfaces.net-hospital.uplink = "uplink-a";
}