61 lines
1.2 KiB
Nix
61 lines
1.2 KiB
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
../../configuration/router
|
|
];
|
|
|
|
profiles.clerie.mercury-vm.enable = true;
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/vda";
|
|
|
|
networking.useDHCP = false;
|
|
systemd.network.enable = true;
|
|
|
|
systemd.network.networks."10-wan" = {
|
|
matchConfig.Name = "ens18";
|
|
address = [
|
|
"2001:638:904:ffca::6/64"
|
|
"141.24.46.169/24"
|
|
];
|
|
routes = [
|
|
{ Gateway = "141.24.46.1"; }
|
|
{ Gateway = "2001:638:904:ffca::1"; }
|
|
];
|
|
linkConfig.RequiredForOnline = "routable";
|
|
};
|
|
systemd.network.networks."10-nat-netz-mercury" = {
|
|
matchConfig.Name = "ens19";
|
|
address = [
|
|
"192.168.10.1/24"
|
|
];
|
|
linkConfig.RequiredForOnline = "no";
|
|
};
|
|
|
|
networking.nat = {
|
|
enableIPv6 = true;
|
|
enable = true;
|
|
externalInterface = "ens18";
|
|
internalInterfaces = [ "ens19" ];
|
|
};
|
|
|
|
networking.firewall.allowedUDPPorts = [];
|
|
|
|
clerie.system-auto-upgrade = {
|
|
allowReboot = true;
|
|
autoUpgrade = true;
|
|
};
|
|
|
|
clerie.monitoring = {
|
|
enable = true;
|
|
id = "103";
|
|
pubkey = "BHRfdK+HsoBXQHgLXotMnfPgfRrsVNHdSg19fvS2kg4=";
|
|
blackbox = true;
|
|
};
|
|
|
|
system.stateVersion = "21.03";
|
|
}
|