45 lines
1.0 KiB
Nix
45 lines
1.0 KiB
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
];
|
|
|
|
profiles.clerie.network-fallback-dhcp.enable = true;
|
|
|
|
boot.kernelParams = [ "console=ttyS0,115200n8" ];
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/sda";
|
|
boot.loader.grub.extraConfig = "
|
|
serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1
|
|
terminal_input serial
|
|
terminal_output serial
|
|
";
|
|
|
|
networking.hostName = "beryllium";
|
|
|
|
networking.useDHCP = false;
|
|
systemd.network.enable = true;
|
|
|
|
networking.firewall.enable = false;
|
|
|
|
profiles.clerie.wg-clerie = {
|
|
enable = true;
|
|
ipv6s = [ "2a01:4f8:c0c:15f1::8107/128" ];
|
|
ipv4s = [ "10.20.30.107/32" ];
|
|
privateKeyFile = "/var/src/secrets/wireguard/wg-clerie";
|
|
};
|
|
|
|
clerie.monitoring = {
|
|
enable = true;
|
|
id = "213";
|
|
pubkey = "hMIr7fgfZwSjNufRaMtq+7MDxfwN3XLJ4ZlmSOoFrz4=";
|
|
serviceLevel ="event";
|
|
privateKeyFile = "/var/src/secrets/wireguard/wg-monitoring";
|
|
};
|
|
|
|
system.stateVersion = "22.11";
|
|
}
|