65 lines
1.2 KiB
Nix
65 lines
1.2 KiB
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
|
|
./nixfiles-updated-inputs.nix
|
|
./polkit-test.nix
|
|
];
|
|
|
|
profiles.clerie.mercury-vm.enable = true;
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/vda";
|
|
|
|
boot.binfmt.emulatedSystems = [
|
|
"armv6l-linux"
|
|
"armv7l-linux"
|
|
"aarch64-linux"
|
|
];
|
|
|
|
networking.useDHCP = false;
|
|
systemd.network.enable = true;
|
|
|
|
systemd.network.networks."10-wan" = {
|
|
matchConfig.Name = "ens19";
|
|
address = [
|
|
"2001:638:904:ffc7::6/64"
|
|
];
|
|
routes = [
|
|
{ Gateway = "2001:638:904:ffc7::1"; }
|
|
];
|
|
linkConfig.RequiredForOnline = "routable";
|
|
};
|
|
systemd.network.networks."10-nat-netz-mercury" = {
|
|
matchConfig.Name = "ens18";
|
|
address = [
|
|
"192.168.10.29/24"
|
|
];
|
|
routes = [
|
|
{ Gateway = "192.168.10.1"; }
|
|
];
|
|
linkConfig.RequiredForOnline = "routable";
|
|
};
|
|
|
|
environment.systemPackages = with pkgs; [
|
|
git
|
|
];
|
|
|
|
nix.gc = {
|
|
automatic = true;
|
|
dates = "weekly";
|
|
options = "--delete-older-than 30d --max-freed 20G";
|
|
};
|
|
|
|
clerie.monitoring = {
|
|
enable = true;
|
|
id = "201";
|
|
pubkey = "REWaiNU9AFSdDEL532XvcRul/rC79ZUfc7NOlwPSZzM=";
|
|
};
|
|
|
|
system.stateVersion = "21.03";
|
|
}
|