45 lines
889 B
Nix
45 lines
889 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
../../configuration/hydra-build-machine
|
|
];
|
|
|
|
profiles.clerie.cybercluster-vm.enable = true;
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/vda";
|
|
|
|
boot.binfmt.emulatedSystems = [
|
|
"armv6l-linux"
|
|
"armv7l-linux"
|
|
"aarch64-linux"
|
|
];
|
|
|
|
networking.useDHCP = false;
|
|
systemd.network.enable = true;
|
|
|
|
systemd.network.networks."10-wan" = {
|
|
matchConfig.Name = "ens18";
|
|
address = [
|
|
"2001:638:904:ffc1::100/64"
|
|
"141.24.50.112/24"
|
|
];
|
|
routes = [
|
|
{ Gateway = "2001:638:904:ffc1::1"; }
|
|
{ Gateway = "141.24.50.1"; }
|
|
];
|
|
linkConfig.RequiredForOnline = "routable";
|
|
};
|
|
|
|
clerie.monitoring = {
|
|
enable = true;
|
|
id = "211";
|
|
pubkey = "aWtxaM6GKhPwIJWRIQSqJwUa6nhfnD89JkkN9bt2NwE=";
|
|
};
|
|
|
|
system.stateVersion = "22.11";
|
|
}
|