16 lines
379 B
Nix
16 lines
379 B
Nix
{ self
|
|
, nixpkgs
|
|
, ...
|
|
}@inputs:
|
|
|
|
let
|
|
|
|
buildHosts = hosts: builtins.mapAttrs (name: host: host.config.system.build.toplevel) (nixpkgs.lib.filterAttrs (name: host: (builtins.substring 0 1 name) != "_") hosts);
|
|
|
|
in {
|
|
inherit (self)
|
|
packages;
|
|
nixosConfigurations = buildHosts self.nixosConfigurations;
|
|
iso = self.nixosConfigurations._iso.config.system.build.isoImage;
|
|
}
|