21 lines
484 B
Nix
21 lines
484 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
services.nginx.virtualHosts = {
|
|
"nogo2024.clerie.de" = {
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
locations."/" = {
|
|
return = "404";
|
|
};
|
|
locations."= /nogo2024.ics" = {
|
|
root = pkgs.fetchgit {
|
|
url = "https://git.clerie.de/clerie/nogo2024.git";
|
|
rev = "09f06098589e1cc37db4cda49841db192b562b1a";
|
|
sha256 = "sha256-4tYyIEpUwR94JzjYy7b1FYBzQooPpT3V0wAEreUQZS4=";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|