17 lines
364 B
Nix
17 lines
364 B
Nix
{ ... }:
|
|
|
|
{
|
|
|
|
# Allow Hydra to fetch remote URLs in restricted mode
|
|
nix.settings.allowed-uris = "http: https: git+https: github:";
|
|
|
|
services.openssh.settings= {
|
|
PermitRootLogin = "yes";
|
|
};
|
|
|
|
users.extraUsers.root.openssh.authorizedKeys.keys = [
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMv8Lbca/CR4das3HJ2F/sQ9dA7kdGS1hSVTt5lX4diP root@hydra-1"
|
|
];
|
|
|
|
}
|