1
0

23 lines
419 B
Nix

{ config, lib, ... }:
with lib;
{
options.profiles.clerie.common-dns = {
enable = mkEnableOption "Common dns config";
};
config = mkIf config.profiles.clerie.common-dns.enable {
# Use systemd-resolved everywhere
services.resolved.enable = true;
# Do not use any DNS servers as fallback
services.resolved.fallbackDns = [];
networking.networkmanager.dns = "systemd-networkd";
};
}