39 lines
868 B
Nix
39 lines
868 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
imports =
|
|
[
|
|
./hardware-configuration.nix
|
|
];
|
|
|
|
profiles.clerie.network-fallback-dhcp.enable = true;
|
|
|
|
boot.kernelParams = [ "console=ttyS0,115200n8" ];
|
|
|
|
boot.loader.grub.enable = true;
|
|
boot.loader.grub.device = "/dev/disk/by-id/ata-InnoDisk_Corp._DRPS-08GJ30AC1QS-A88_20120705AAB200000505";
|
|
boot.loader.grub.extraConfig = "
|
|
serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1
|
|
terminal_input serial
|
|
terminal_output serial
|
|
";
|
|
|
|
networking.hostName = "tungsten";
|
|
|
|
profiles.clerie.wg-clerie = {
|
|
enable = true;
|
|
ipv6s = [ "2a01:4f8:c0c:15f1::8112/128" ];
|
|
ipv4s = [ "10.20.30.112/32" ];
|
|
};
|
|
|
|
clerie.monitoring = {
|
|
enable = true;
|
|
id = "216";
|
|
pubkey = "bDmf4xndBNwzcvIGCMq6dhyzjdEZOV2ckhv/37V/PWg=";
|
|
serviceLevel = "event";
|
|
};
|
|
|
|
system.stateVersion = "25.05";
|
|
}
|
|
|