1
0
Fork 0
nixfiles/hosts/hydra-1/build-machines.nix

37 lines
948 B
Nix

{ ... }:
{
nix = {
distributedBuilds = true;
buildMachines = [
# {
# hostName = "hydra-1.net.clerie.de";
# sshUser = "root";
# systems = [
# "x86_64-linux"
# "armv6l-linux"
# "armv7l-linux"
# "aarch64-linux"
# ];
# sshKey = "/var/lib/hydra/id_ed25519";
# }
{
hostName = "hydra-2.net.clerie.de";
sshUser = "root";
systems = [
"x86_64-linux"
"armv6l-linux"
"armv7l-linux"
"aarch64-linux"
];
sshKey = "/var/lib/hydra/id_ed25519";
}
];
};
programs.ssh.knownHosts."hydra-1.net.clerie.de".publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIE2xQBCsFBCwL9n4OP/bPngtNO1fy9kPw13Z/NDoba16 root@hydra-1";
programs.ssh.knownHosts."hydra-2.net.clerie.de".publicKey = "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIDZED9QM+qe7sB6R6atvP6WNaI2sC2nh7TTsD6kgRpnr root@hydra-2";
}