1
0
Fork 0
nixfiles/hosts/backup-4/restic-server.nix

31 lines
728 B
Nix

{ ... }:
{
services.restic.server = {
enable = true;
privateRepos = true;
dataDir = "/mnt/backup-4/magenta";
listenAddress = "[::1]:43242";
};
# restic rest server does not support --htpasswd-file in the current version of nixpkgs
# until then we copy the secrets to the common location
age.secrets.restic-server-magenta-htpasswd = {
path = "/mnt/backup-4/magenta/.htpasswd";
symlink = false;
owner = "restic";
group = "restic";
};
services.nginx.virtualHosts."magenta.backup.clerie.de" = {
enableACME = true;
forceSSL = true;
locations."/" = {
proxyPass = "http://[::1]:43242/";
extraConfig = ''
client_max_body_size 10G;
'';
};
};
}